Installing FreeCAD 0.10 in Ubuntu Lucid

Hello to all. Today I am going to explain the procedure to install FreeCAD 0.10 on Ubuntu Lucid.

Firstly, What is FreeCAD?

FreeCAD is a general purpose Open Source 3D CAD/MCAD/CAx/CAE/PLM modeler, aimed directly at mechanical engineering and product design but also fits in a wider range of uses around engineering, such as architecture or other engineering specialties. It is a feature-based parametric modeler with a modular software architecture which makes it easy to provide additional functionality without modifying the core system.

FreeCAD is based on OpenCasCade, a powerful geometry kernel, features an Open Inventor-compliant 3D scene representation model provided by the Coin 3D library, and a broad python API. The interface is built with Qt. FreeCAD runs exactly the same way on Windows, Mac OSX and Linux platforms.

Simple steps to successfully install and run FreeCAD 0.10-:

  • Install FreeCAD 0.9 using ubuntu repositories.

To do that type the following command on terminal.

$sudo apt-get install freecad

As currently Ubuntu repositories provide FreeCAD 0.9, so above command install FreeCAD 0.9 on your system. You can also use Ubuntu package manager instead of above command.

  • Verify the installation.

To verify the installation run FreeCAD from Applications -> Graphics ->FreeCAD or by giving following command on terminal-:


Note-: Bug in python-pivy package provided by Ubuntu repositories.

If you are unable to draw any 2-D component such as line, circle, rectangle etc. and FreeCAD is giving your errors much likely as shown bolow-:

Error: Draft_line command not found

This means there is a bug in python-pivy package which is used by FreeCAD to draw all 2-D figures. Next step will explain how to remove this bug. If you are not facing this type of error may be Ubuntu has resolved this issue then you can skip the next step.

  • Resolving buggy python-pivy error

Firstly, remove existing python-pivy package with this command.

$ sudo apt-get remove python-pivy

Now, download the latest python-pivy package from debian. Download the package appropriate for your CPU architecture from the link below-:

Download python-pivy

Install this .deb package by double clicking on it or by this command-:

$ dpkg -i python-pivy*.deb

  • Install FreeCAD 0.10

I have experienced some problems with FreeCAD 0.9, one is the shape of circle is not perfectly round. So it would be better to use FreeCAD 0.10 and stay updated. For that, download FreeCAD 0.10 (.deb package) from following link-:

FreeCAD from

Be sure to download .deb package available under FreeCAD Linux.

Now remove existing FreeCAD 0.9 package with this command-:

$ sudo apt-get remove freecad

At last, install the downloaded FreeCAD 0.10 .deb package by double clicking on it or via following command-:

$sudo dbpkg -i freecad_*.deb

Now run the new FreeCAD installation and Enjoy.

Have Fun !!.

4 thoughts on “Installing FreeCAD 0.10 in Ubuntu Lucid

  1. Pingback: Daily Diary(6 months) | Mandeep Simak

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s